Welcome to SpectrumVoIP's Status page, home to service-related updates. Here, you will find information regarding outages, scheduled maintenance, and general notices with real-time updates.

New Geoblock Whitelist Requests Limited

Incident Report for SpectrumVoIP

Resolved

This incident has been resolved. Please contact support regarding registering for international agents only.
Posted Sep 02, 2026 - 12:58 CDT

Identified

The issue has been identified and a fix is actively being worked on and will be applied to the system soon.
Posted Sep 02, 2026 - 09:45 CDT
This incident affected: Stratus.