Welcome to SpectrumVoIP's Status page, home to service-related updates. Here, you will find information regarding outages, scheduled maintenance, and general notices with real-time updates.

Toll-free number outbound call fail - Minor

Incident Report for SpectrumVoIP

Resolved

This incident has been resolved.
Posted Jul 16, 2026 - 18:13 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2026 - 17:40 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 16, 2026 - 17:27 CDT

Update

We are continuing to investigate this issue.
Posted Jul 16, 2026 - 16:50 CDT

Investigating

We are currently investigating an issue of some toll-free numbers unable to be dialed outbound. Please try the respective local number while we work on resolving this issue.
Posted Jul 16, 2026 - 16:50 CDT
This incident affected: Stratus.