Welcome to SpectrumVoIP's Status page, home to service-related updates. Here, you will find information regarding outages, scheduled maintenance, and general notices with real-time updates.

Minor service degradation - Dallas area

Incident Report for SpectrumVoIP

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 20:42 CDT

Identified

We have identified an issue resulting in minor service degradation to some users in the Dallas area. Our engineers are currently working on implementing on a fix.
Posted Jul 22, 2026 - 16:57 CDT
This incident affected: Stratus.